Command Line Berikut ini merupakan perintah perintah dasar Mikrotik yang umum digunakan :

Teks penuh

(1)

Command Line

Berikut ini merupakan perintah perintah dasar Mikrotik yang umum digunakan : 1. Perintah untuk shutdown dan restart computer , ketikkan :

[admin@MikroTik]>system shutdown (Untuk shutdown komputer ) [admin@MikroTik]>system reboot (Untuk restart computer )

[admin@MikroTik]>system reset (Untuk meret konfigurasi yang sudah dibuat sebelumnya). Dan perlu diperhatikan bahwa perintah – perintah tersebut harus dilakukan pada direktori admin.

2. Perintah untuk merubah nama mesin Mikrotik , ketikkan : [admin@MikroTik]>/system identity

[admin@MikroTik]>system identity > set name=proxy

Untuk melihat hasil konfigurasi , ketikkan “print” atau “pr” Contok [admin@MikroTik]system indentity>pr name:”proxy” Lalu console berubah menjadi [admin@proxy]

3. Perintah merubah password mesin MikroTik , ketikkan [admin@proxy]>/ password

[admin@proxy]password>old password (jika sebelumnya anda belum mengeset password maka ketikkan kosong)

[admin@proxy]password>new password:……(ketikkan password yang baru)

[admin@proxy]password>retype new password: ……..(masukkan sekali lagi passowrdnya) Sebagai contoh :

Jika password lama kosong dan password baru ABCD, maka perintahnya adalah sebagai berikut : [admin@proxy]>/password

[admin@proxy]password>old password

[admin@proxy]password>new password ABCD [admin@proxy]password>retype new password ABCD

4. Perintah untuk melihat kondisi interface pada Mikrotik Router : [admin@Mikrotik] > interface print

Flags: X – disabled, D – dynamic, R – running

# NAME TYPE RX-RATE TX-RATE MTU 0 R ether1 ether 0 0 1500 1 R ether2 ether 0 0 1500 [admin@Mikrotik]>

Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi etherned cardnya, seharusnya R (running).

a. Mengganti nama interface [admin@Mikrotik] > interface(enter)

b. Untuk mengganti nama Interface ether1 menjadi Public (atau tersenamanya),maka: [admin@Mikrotik] interface> set 0 name=Public

c. Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka [admin@Mikrotik] interface> set 1 name=Local

d. atau langsung saja dari posisi root direktori, memakai tanda “/”, tanpa tanda kutip [admin@Mikrotik] > /interface set 0 name=Public

e. Cek lagi apakah nama interface sudah diganti. [admin@Mikrotik] > /interface print

Flags: X – disabled, D – dynamic, R – running

(2)

0 R Local ether 0 0 1500 1 R Public ether 0 0 1500 5. Perintah untuk melihat paket sofwtware MikroTik OS : [admin@proxy]>/system package

[admin@proxy]system package><ketikkan print atau pr>

Dengan perintah diatas maka akan tampil paket softwore yang ada dalam MikroTik Os Contoh : [admin@MikroTik system package> pr

Flags : x – disabled # Name 0 X routing – test 1 dhcp 2 radiolan 3 user-menejer 4 X webproxy-test 5 arlan 6 isdn 7 hotspot-fix 8 ppp 9 wireless 10 web-proxy 11 hotspot 12 advanced-tools 13 security 14 Telephony 15 routing 16 synchronous 17 system 18 routerboard 19 rstp-bridge-test 20 X wireless-legecy VERSION 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 2.9.27 SCHEDULED

Untuk melihat lebih detailnya, ketikan :

[admin@proxy]system package > pr detail fl gs : x – disabled

0 x name=”routing-test” version=”2.9.27” build – time =jul/03/2006 10:57:53 scheduled 1 name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56:37 schedule

2 name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56: 44 schedule 3 name=”web-proxy” version=”2.9.27” build-time=jul/03/2006 10:`58 :03 schedule

4 name=”advanced –tools” version=”2.9.27” build –time=jul /03/2006 10:56 : 41 scheduled=””

5 name=”dhcp” version=”2.9.27” build-time=jul/03/2006 10:56:45 scheduled=””

6 name =”hotspot”version=”2.9.27”build-time=jul/03/2006 10:56:58 scheduled=””

7 x name=”webproxy-test” version=”2.9.27” build-time=jul / 03 /2006 10:57:52 scheduled

8 name=”routerboard” version =”2.9.27” build-time=jul / 03 / 2006 10: 57 : 17 –[q quit ׀ D dump ׀ up ׀ down ] 6. Perintah untuk mengupgrade paket software router :

[admin@Mikrotik] system upgade> To upgrade chosen packages :

Download 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14

7. Perintah mengaktifkan paket software yang ada dalam MikroTik OS : [admin@Mikrotik]system page>

(3)

Enable <ketikkan paket yang dikehendaki> Contoh :

[admin@proxy] system package> enable dhcp

8. Perintah merubah nama ethernet pada mesin MikroTik OS: [admin@proxy]>/interface

[admin@proxy]interface>ethernet set etherl nama=public Atau dengan menggunakan perintah

[admin@proxy]interface>set<ketikan number ethernet yang terpasang> name=<nama ethernet yang baru >

contoh :

[admin@proxy]interface> set 0 name=public [admin@proxy]interface>set 1 name=lan Atau

[admin@proxy]interface>

set 0 name=public; set 1 name=lan

9. Perintah setting IP address pada mesin MikroTik OS : [admin@proxy]> ip address

[admin@proxy]ip address>

Add interface=<nama interface>anddress= (ketikkan IP address/subnet mask interface) Contoh :

Jika nama interfacenya “lan” dan IP address yang dikehendaki : 192.168.01 dan subnet mask : 255.255.255.0, maka perintahnya sebagai berikut

[admin@proxy]>/ ip address [admin@proxy]ip address >

Add interface=lan address = 192.168.0.1/24

10. Perintah setting IP DNS primaty dan Secondary :

[admin@proxy]./ip dns [admin@proxy]ip dns>

Set nama-dns>=<Ip dns dari ISP> Contoh :

Jika IP DNS primary ISP : 202.134.1.10 dan secondary: 202.134.0.0155, maka perintahnya adalah sebagai berikut : [admin@proxy]./ip dns

[admin@proxy]ip dns> Set primary-dns= 202.134.1.10 [admin@proxy]ip dns>

Set secondary-dns=202.134.0.155

11. Perintah setting IP Gateway pada mesin MikroTik OS [admin@proxy]>/ip route

[admin@proxy]ip route >add gateway=<ip gatway

Contoh IP gateway dari ISP : 202.134.1.1, maka perintahnya : [admin@proxy]>/ ip route

[admin@proxy] ip route> add gateway=202.134.1.1

12. Perintah Network address Translate (NAT) pada mesin MikroTik OS [admin@proxy]>/ip firewall nat

(4)

[admin@proxy]ip firewall nat>

add chain=srcnat out-interface=<etherface yang terhubung dengan jaringan WAN> scr-address=

<network-id interface yang terhubung dengan LAN / subnet mask interface LAN> action=masqurade

Contoh :

jika network-id interface LAN :”192.168.0.0” dan subnet

Mask :”255.255.255.0”. untuk interface mesin MikroTik OS yang terhubung ke jaringan WAN : “pubilk”, maka perintahnya sebagai berikut :

[admin@proxy] >/ip firewall nat [admin@proxy[ ip firewall nat>

Add chain=srcnat out-interface=public

Scr-address=192.168.0.0/24 action=masquerade

Command Line - Configuration Mikrotik

Part I

[1]- pastikan setting pada virtual box seperti gambar di bawah ini

Attached to : Bridged Adapter (sesuaikan dengan jaringan anda)

Name : ***** ( sesuaikan dengan jaringan anda misal anda mengunakan Wifi/Lan)

Promiscuous Mode : Allow All

(5)

[2]- kemudian klik tombol

start.

setelah masuk mikrotik ketiklah perintah seperti di bawah

ini. ini di maksudkan agar settingan kita sebelumnya terhapus. agar mikrotik benar- benar

bersih dari setting konfigurasi yang lain. kemudian pilih [y] untuk mereset. kemudian

mikrotik akan reboot.

[3]- setelah mikrotik melakukan reboot. maka ketikkanlah perintah di bawa ini untuk

menggantikan nama

admin@

Mikrotik, menjadi nama anda

admin@

dani.

[4]- ketikkan "

interface pr

" tanpa tanda petik. untuk mengecek kondisi Ethernet apa sudah

terinstal. kalau ada tanda X berarti tidak jalan/ disable. perhatikan urutan no di bawah

lambang "#".

[5]- perhatikan urutan no di bawah lambang "#". ada no 0,1,2 adalah kode lain dari

ether1,ether2,ether3. kali ini kita menganti nama dari ether1,ether2,ether3. Agar nantinya

sesuai dengan nama jaringan yang akan kita buat. ketikkan code di bawah untuk mengganti

nama ether tadi.

(6)

jika perintah yang kalian lakukan di atas benar maka, ketika anda mengetikan "interface

pr

"

akan tampil seperti di bawah.

[6]- setelah kita memberi nama ether tadi, sekarang saatnya untuk memberi IP pada

masing-masing ether. untuk lebih jelasnya liatlah code di bawah ini. ingat sesuaikan dengan topogi

yang telah kita rancang sebelumnya.

[6]-

kemudian buatlah gateway, sesuaikan dengan kelas IP pada "ether1-WAN" anda.

dengan

mengetikan

kode

di

bawah

ini.

[7]- Kemudian kita mengaktikan DNS, ini berfungsi untuk mendapatkan akses internet. disini

kita pakai DNS default punya google. Atau anda juga bisa memasukan DNS bawaan Punya

Speedy.

[8]-

ketik "ip dns

print

" untuk melihat apakah konfigurasi DNS sudah benar. jika tidak

tertulis "servers: 8.8.8.8" kemungkinan konfigurasi anda salah.

(7)

[9]-

untuk kenyamanan jaringan biasanya admin menambahakan alternated DNS. cara

menambahakan DNS alternated ada seperti di bawah ini.

[10]- Cek konfigurasi anda dengan mengetikan "ip dns

print

"

[10]-

"ping

google.com" untuk mengetes. apa internet sudah jalan di mikrotik anda.

[11]- untuk sementara internet hanya berjalan di mikrotik anda, client belum mendapatkanya.

agar client pada ether2-LAN dan ether3-HOTSPOT. maka kita akan mengaktifkan NAT.

[12]- untuk memastikan sudah berjalan terkonfigurasi NAT nya ketikkaan code

"

ip firewall

nat

pr

".

[13]- langkah terakhir. cek apakan IP di ether2-LAN sudah bisa mengakses internet dengan

mengetikan kode di bawah ini.

[14]- okelah. sekarang kita mengetes apakah jaringan pada ether3-HOTSPOT berfungsi

dengan mengetikan "

ping www.cdn.net.id

src-address=

192.168.101.1

"

(8)

Command Line - Configuration Mikrotik

Part II (DHCP+Firewall)

PENGERTIAN DHCP

DHCP (Dynamic Configuration Protocol) adalah layanan yang secara otomatis memberikan nomor IP kepada komputer yang memintanya. Komputer yang memberikan nomor IP disebut sebagai DHCP server, sedangkan komputer yang meminta nomor IP disebut sebagai DHCP Client. Dengan demikian administrator tidak perlu lagi harus memberikan nomor IP secara manual pada saat konfigurasi TCP/IP, tapi cukup dengan memberikan referensi kepada DHCP Server.

Pada saat kedua DHCP client dihidupkan , maka komputer tersebut melakukan request ke DHCP-Server untuk mendapatkan nomor IP. DHCP menjawab dengan memberikan nomor IP yang ada di database DHCP. DHCP Server setelah memberikan nomor IP, maka server meminjamkan (lease) nomor IP yang ada ke DHCP-Client dan mencoret nomor IP tersebut dari daftar pool. Nomor IP diberikan bersama dengan subnet mask dan default gateway. Jika tidak ada lagi nomor IP yang dapat diberikan, maka client tidak dapat menginisialisasi TCP/IP, dengan sendirinya tidak dapat tersambung pada jaringan tersebut.

Setelah periode waktu tertentu, maka pemakaian DHCP Client tersebut dinyatakan selesai dan client tidak memperbaharui permintaan kembali, maka nomor IP tersebut dikembalikan kepada DHCP Server, dan server dapat memberikan nomor IP tersebut kepada Client yang membutuhkan. Lama periode ini dapat ditentukan dalam menit, jam, bulan atau selamanya. Jangka waktu disebut leased period.

KELEBIHAN DHCP

1. Memudahkan dalam transfer data kepada PC client lain atau PC server.

2. DHCP menyediakan alamat-alamat IP secara dinamis dan konfigurasi lain. DHCP ini didesain untuk melayani network yang besar dan konfigurasi TCP/IP yang kompleks.

3. DHCP memungkinkan suatu client menggunakan alamat IP yang reusable, artinya alamat IP tersebut bisa dipakai oleh client yang lain jika client tersebut tidak sedang menggunakannya (off). 4. DHCP memungkinkan suatu client menggunakan satu alamat IP untuk jangka waktu tertentu dari server.

5. DHCP akan memberikan satu alamat IP dan parameter-parameter kofigurasi lainnya kepada client. CONFIGURATION DHCP

(9)

[2]- Tampilan dhcp_pool1 sudah terconfigurasi dengan ether1-LAN.

[3]- Tampilan address dan gatewway yang sudah di tambahkan

[4]- Tampilan dhcp_pool1 dan range IP yang diberikan 192.168.100.2 - 192.168.100.254

FIREWALL SEDERHANA

Sebagai tambahan keamanan dapat menggunakan firewall sederhana ini,agar mikrotik anda makin Joss.

Lakukan penambahan Firewall ini secara berurutan

[1]- Menerima paket icmp (misal ping) dari semua interface

[2]- Menerima semua paket dengan connection-state=established dari ether1-WAN

(10)

[4]- selain paket-paket di atas yang menuju ether1-WAN akan didrop/dibuang [5]- Tampilan Firewall yang sudah ditambahkan

(11)

Command Line - Configuration Mikrotik

Part III (Hotspot)

[1]- SETUP HOTSPOT MIKROTIK

paling mudah menurut saya bisa menggunakan Mikrotik, ada fasilitas IP- HOTSPOT. Hotspot disini tidak harus berupa Wifi, tetapi jaringan Kabel-pun bisa anda setup jadi seperti hotspot. setiap pengguna yang ingin login harus memasukkan user/password ketika pertama kali browsing. misal seperti tampilan digambar berikut, misal pertama kali user yang akan mengakses situs tertentu akan redirect ke halaman login.

Langkah-Langkah setup HOTSPOT Mikrotik : [1]- Tampilkan interface pr

Misal Kita mempunyai 3 interface : ether1-WAN-> ke Internet

ether2-LAN-> ke LAN tanpa Hotspot

ether3-HOTSPOT -> ke LAN yang akan di setup jadi Hotspot.

(12)

a. pilih ethernet b. Seting IP

c. Seting DHCP IP pool(batasan IP untuk DHCP) d. Sertifikat(none saja)

e. SMTP biarkan 0.0.0.0 saja

f. DNS sesuaikan dengan DNS anda, atau tanyakan ISP anda g. DNS name untuk Hotspot anda, isikan www.smkn1skw.com

Tampilkan server hotspot yang telah di buat tadi ketik ip hotspotprint.

Tampilan ip poolprint, untuk menampilkan ip. ip pool adalah range ip yang di berikan pada client. yaitu dari 192.168.101.2-192.168.101.254

Tampilan dhcp-server, dhcp2 di ether3-hotspot dengan address-pool=hs-pool-3 telah aktif dengan Lease-time 1h.

(13)

Tampilan bahwa di address 192.168.101.0/24 gateway telah diberikan gateway 192.168.101.1.

ip firewal nat telah aktif untuk hotpsot

[2]- Membuat User Profil

Dalam Mikrotik hotspot memberikan kemudahan kita untuk men-setup user dengan profil yang berbeda, misalnya ada 2 profil user VIP dan biasa. Dimana VIP bisa memperoleh kecepatan akses yang lebih dari user biasa, meskipun sama-sama menggunakan fasilitas hotspot.

Dalam gambar di bawah ini saya akan cara membuat profil hotspot untuk jurusan TKJXIIA.

Tampilan profile TKJXIIA yang telah di buat tadi.

[3]- Menambah User Baru

(14)

Cek user yang telah di add tadi, yang bernama rachman

Figur

Memperbarui...

Related subjects :